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Page View’s Screen Areas

When you launch FrontPage for the first time, a dialog box explains that the program is trying to 
determine your machine’s network address or local machine name. Once that process is completed 
and you press OK, you find yourself faced with FrontPage’s default multipart interface. This is your 
workspace; you can do everything from here, by switching among the various FrontPage views.

Figure 3.1 shows the default interface. As with essentially all Windows software, the title bar runs 
across the top of the screen, with the menu bar immediately below it. Below that comes the standard 
toolbar and then the formatting toolbar.

FIGURE 3.1 The Folder List appears automatically when you enter Folders, Navigation, or 
Hyperlinks view. 

FrontPage’s three largest screen areas are below these typical components. At the far left is the views 
bar, and on the right is the largest screen area, the main viewing window. In Page view, in which 
FrontPage starts by default, only these two areas appear. When you switch to any other view, the 
Folder List appears between the Views bar and the main viewing window. This chapter deals 
exclusively with the Page view.

What you actually see, in fact, depends on other things as well. See "Customizing and Creating 
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Toolbars," below, for some ways of changing the interface features. Page view itself offers three tabs 
at the bottom of the screen: Normal, HTML, and Preview. Each changes the look of the main viewing 
window (although not the layout of the screen areas), and each alters the menu commands and the 
right-click menu for specificity.

The Page view is your document editor. In essence, it is the word processor portion of the FrontPage 
package. You create, format, and edit documents in a word processor, and that’s precisely what you 
do in Page view. From there, in other words, you build the contents of your Web site. In that sense, 
Page view is FrontPage’s workhorse, the area in which you’ll spend most of your time.

In earlier versions of FrontPage, document editing and formatting were separated from site creation 
and management. FrontPage Editor handled the former, FrontPage Explorer the latter. While the 
distinction offered some useful functionality, including hiding the gory details of site management 
from those who were assigned solely to authoring tasks, it also caused confusion. For instance those 
launching FrontPage saw Explorer first and found themselves staring at a screen that had no obvious 
means of creating their Web pages, which is usually what they bought FrontPage for in the first place. 
Even for more experienced users there was some confusion: Explorer let you create individual 
documents--as did Editor--and it wasn’t always clear how the two fit together or how working with 
one affected the other.

FrontPage 2000 brings Page view to the forefront, making it obvious that document editing and 
creation is fully a part of site management.

Title Bar, Menu Bar, and Toolbars

The title bar runs along the top of the FrontPage screen. This bar always displays the name of the 
product itself, Microsoft FrontPage, and, if you have a web open, the directory path of that web. 

When you save a document to a web, the name of the web appears in the title bar. If you save a 
document to a non-web location such as a data folder on your hard drive, that location’s pathname 
appears in the title bar. The name of the document itself appears only on the grayed bar above the 
main window.

The menu bar contains the headings for each of the program’s menus. As with all Windows software, 
you can click a menu to reveal the items beneath it, or you can access it by pressing the Alt key and 
simultaneously pressing the underlined character in the heading. To access the Table menu, for 
example, hold Alt and press the A key.

The menus are covered in detail in this chapter’s "Page View’s Menu Bar" section.

The standard toolbar contains a series of icons, each of which corresponds to a FrontPage command 
or option. Most of them can be accessed with a simple click, although some display a down arrow 
next to them. In these cases, clicking the icon performs the default task associated with that icon, 
while clicking the down arrow reveals a submenu. In one case, the help icon at far right, the down 
arrow leads to another down arrow.

The formatting toolbar also contains a series of icons corresponding to FrontPage commands or 
options. In addition, it also contains the Style, Font, and Font Size drop-down lists, which are active 
only when you start a new web document or open an existing one. To access the drop-down lists, 
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click the down arrow to the right of the default entry in the lists: (None) for Style, (default font) for 
Fonts, and (Normal) for Font Size.

You can modify one or both of these toolbars to suit your needs. You can also move them by clicking 
and dragging them, as well as reordering and resizing them.

All toolbar details, as well as details about other FrontPage toolbars, are covered in this chapter’s 
"FrontPage’s Toolbars" section.

Views Bar

The Views bar appears by default down the left side of the screen. From here you can access the 
various FrontPage views; you can do the same from the View menu on the menu bar. This chapter 
discusses only the Page view, accessible by clicking the topmost icon. All other views are detailed in 
Part III, "Web Creation and Management."

You can’t move the Views bar, but you can hide it. To do so, right-click anywhere on the Views bar 
(even on an icon; it makes no difference where) and select Hide Views Bar. Alternatively, deselect 
Views Bar from the View menu.

Whether you hide the Views bar by right-clicking it and selecting Hide Views Bar, or unselecting it 
from under the View menu, the only way to bring the Views bar back is by selecting it from under the 
View menu. 

Folder List

When you open a document file in Page view, the contents of the web or non-web folder in which 
that document resides appear in the Folder List. These contents are presented as a list of folders and 
documents; the folders are collapsible. The Folder List lets you easily access any file within the folder 
for editing, without having to switch from the Page view to the Folders view.

Right-clicking in the Folders view brings up a context menu. If you right-click in the whitespace 
(away from the folder and document names), you can add a new page or a new folder, you can paste a 
page from the clipboard, or you can display the directory above the current directory (through the 
menu item called Up One Level). You have the following options when you right-click a document 
name:

l Open--Open the file either into FrontPage Editor or into the editor associated with that file 
type.

l Open With--Open the file into an editor of your choosing. This option is useful if you have an 
editor besides FrontPage that you like to use, or if you have a file associated with a program 
that you want to open with a different graphics package.

l Cut--Cut the file from the list.

l Copy--Copy the file into the Clipboard.

l Paste--Paste the file that’s currently in the Clipboard to the web. It will appear in the Folder 
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List. The Paste option appears only if there is something to paste.

l Rename--Rename the document.

l Delete--Delete the document from the web.

l Add Task--Add a task for the currently selected document to the Tasks list. See Chapter 18 for 
coverage of the Tasks features.

l Properties--Call up the Properties dialog box for that document. The contents of this dialog box 
are covered in Chapter 4.

The same Context menu appears when you right-click a folder name instead of a document name, 
except that the Add Task option is grayed out and cannot be used. You can associate tasks only with 
documents, not with folders.

Main Window

The main window in Page view shows the contents and the format of the currently selected 
document. You can load a document into the main window the following ways:

l Double-clicking the document’s name in the Folders list

l Selecting File, Open and choosing the document from the Open File dialog box (covered in 
"Page View’s Menu Bar," in this chapter)

l Clicking the open icon from the standard toolbar and selecting the document from the Open 
File dialog box (covered in "Page View’s Menu Bar")

Once the file is loaded, you can work with the document through the commands and options on the 
menus and toolbars. (See "Page View’s Menu Bar" and "FrontPage’s Toolbars" in this chapter, as well 
as the remainder of Part II for detailed discussions of these options.) You also have access to context 
menus by right-clicking in the document. Right-clicking text reveals one set of options, right-clicking 
a hyperlink another set, right-clicking a graphic another set, and so on. Options common to most of 
these menus are as follows:

l Cut, Copy, Paste, Paste Special--These are the common editing features. They correspond to 
the same commands on the Edit menu.

l Theme--Brings up the Theme dialog box, which is covered in Chapter 6.

l Shared Borders--Brings up the Shared Borders dialog box, covered in Chapter 7.

l Properties menus--You can access the Page, Paragraph, Font, Hyperlink, Bookmark, and other 
properties menus through this Context menu. They are covered throughout Part II.

Page View’s Menu Bar
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When you are working in Page view, the FrontPage menus contain the commands and options 
relevant to document creation and editing. Some of these commands are also available as context 
menus by right-clicking in various screen areas, as covered earlier in this chapter and throughout Part 
II. The contents of the menus are covered here, but only with commands and options not covered in 
chapters related specifically to those items are dealt with in detail here.

The File Menu

The File menu covers a range of possible activities, and not all of them have to do specifically with 
files. As with the majority of Windows software, the File menu collects commands that deal with 
files, documents, printing, and related activities. FrontPage is no different in this regard.

The items in the File menu are as follows:

l New--Start a new page, a new task, or a new web from the submenu.

l Open--Bring up the Open File dialog box (see Figure 3.2).

l This dialog box’s main area is the file window, which shows icons representing the subfolders 
and files within the folder that is specified in the Look In field at the top of the dialog box. To 
the left is the list of frequently accessed folders; clicking in one of these folders reveals the 
contents of that folder (files and subfolders) in the file window. You can browse your computer 
(or networked computers) using the Look In field and the file window, or you can type the full 
path of the requested file in the File Name field. You can specify the type of file you want to 
load in the Files of Type field. By default, this field displays FrontPage document types such as 
HTML or ASP, but you can select from a wide variety of additional types by clicking the down 
arrow. The File Name field also offers a down arrow, and clicking it reveals recently loaded 
files for you to choose from.

l You don’t need to specify a local computer location for a file. You can select files from 
computers on your network, for instance, and you can also type in a Web location (URL). If 
your site is on a remote server, you’ll want to access that server, not your local drive, in which 
case type the URL for your site. You are prompted for a username and password if the site is 
password protected; you then have access to the remote folders and files.

l The Open button in the bottom-right corner becomes available when a document is selected. 
There is a down arrow beside that, which lets you choose between opening the document in the 
current FrontPage window or in a new FrontPage window. If the latter, a new instance of 
FrontPage loads with that document in the main window.

l To the right of the Look In field, along the top of the Open File dialog box, is a series of 
navigation icons. The left arrow changes the location displayed in the Look In field to the 
location that was displayed before you selected the current location. The left up arrow takes 
you up one level in the folder hierarchy. The Internet Explorer icon (no, you can’t change it) 
takes you to IE’s search engine, which lets you search using other search engines on the Web. 
With these search engines you can search for files on the Web; once you have located the one 
you want, FrontPage lets you load that file and work with it. The X lets you delete a file or 
folder, while the file folder icon lets you add a folder.
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l The final two icons offer several choices, and thus provide down arrows. The first, Views, lets 
you choose how to display the files in the file window. List view, which gives you a simple list 
of folder and filenames, is selected by default. Selecting details gives you a columnar view of 
the folder and filenames, complete with the files size, type, and last date and time of 
modification.

l If you choose Properties, the file window splits into two panes, with folder and filenames on 
the left and the properties for the selected folder or file on the right. If you choose Preview, the 
file window also splits in half, this time with the right side offering a preview of the page (how 
it will appear in a browser, for example).

l The last icon is called Tools. From here you can search for Files (Find), delete or rename a file, 
print a document, or get the file’s or folder’s properties. You can also map your local network’s 
drives (yielding Windows’ standard dialog box for doing so) or add the chosen folder or file to 
the Favorites folder. Doing so adds a shortcut in the Favorites folder to the specific folder or 
file location. You can access Favorites from the Open File dialog box or a host of other 
Microsoft programs, including Internet Explorer and the Office suite.

l Close--Closes the current document.

l Open Web--Brings up the Open Web dialog box. This is a slightly simplified version of the 
Open File dialog box described earlier. The differences are as follows: The File Name field has 
been replaced by a Folder Name field, the Files of Type field has disappeared, the Open button 
has no down arrow (which means no options), and the Tools button offers only five options--
Delete, Rename, Add to Favorites, Map Network Drive, and Properties.

l To open a web on a remote server, type the URL in the Folder Name field.

l Delete Web--Yields the Confirm Delete dialog box. Here you can choose between removing 
the web entirely by deleting all files and folders, or simply deleting FrontPage information 
within the web. If you choose the latter, all files and folders remain in place, so you can work 
on the web as a non-FrontPage web.

l Note that you can remove webs from local drives, network drives, or remote servers. You can’t 
bring a deleted web back.

l Save--Saves the document currently open in the main window to the folder in which it 
currently resides. If the document has never been saved, this command operates as the Save As 
command (immediately following).

l Save As--Brings up the Save As dialog box. This is very similar to the Open File dialog box 
shown in Figure 3.2, with the following changes: The Open button has been replaced by a Save 
button with no options arrow; the Files of Type field is now called Save as Type; and the 
possible file types are much more limited. The title of the current document (the HTML title, 
not the filename) is shown above the File Name field. A Change button beside this title opens 
the Set Page Title dialog box in which you can simply type in a new title for the page, click 
OK, and thus make that change.
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FIGURE 3.2 The Open File dialog box is common to the Office 2000 suite. The easily accessible 
typical folders are to the left. 

l Publish Web--Yields the Publish FrontPage Web dialog box for the purpose of uploading the 
files and folders of the currently opened web to a remote server. This feature is covered in 
Chapter 16.

l Import--Brings up the Import File to FrontPage Web dialog box, with which you can bring 
existing files (such as word processor documents) into the currently loaded web.

l Preview in Browser--Displays the Preview in Browser dialog box, letting you display the 
currently loaded page in a Web browser. This dialog box is covered in Chapter 4.

l Page Setup--Selecting this option gives you the Windows Print Setup dialog box, from which 
you select the printer you want to use for the currently loaded document, plus features specific 
to that printer. This is a Windows function, not a FrontPage-specific function.

l Print Preview--When selected, FrontPage’s main window changes to show what the currently 
loaded document will look like when printed. From this window you can zoom in to see the 
page in more detail, print the document, and close the window and return to the regular main 
window. For documents that take up more than one printed page, you can choose Next Page, 
Prev Page, or Two Pages to see two pages at the same time.

l Print--Yields the standard Windows Print dialog box. This is a Windows function, not a 
FrontPage-specific function.

l Send--As with other Windows software, Send allows you to email the document. The 
command automatically opens a new message window in your default Windows email 
program. The currently selected document automatically appears in this message as an 
attachment.

l Properties--Brings up the Page Properties dialog box. This box is covered in Chapter 4.

l Recent Files--This selection cascades to reveal the names of the files you have worked on most 
recently. Up to eight filenames are included. Simply select the desired file; it loads into the 
main FrontPage window.

l Recent Webs--This selection cascades to reveal the names of the webs you have most recently 
loaded into FrontPage. Up to four webs are included. Selecting a web name opens that web into 
a separate FrontPage instance.

l Exit--Exits the program, prompting you for save information.

The Edit Menu

The Edit menu contains commands that let you (not surprisingly) edit documents. Most of the 
commands mimic those of the Edit menu in other Windows programs.



Special Edition Using Microsoft FrontPage 2000 - Chapter ...: Windows, Icons, and Menu Page 8 of 15

file://I:\chapters\i\ir141.html 3/22/01

l Undo--This command resets the text of the document to what it was before your last action 
(typing, deleting, inserting, and the like). Each Undo action removes one action, and the 
number of possible undos depends on your system’s memory. The actual command reads Undo 
X, where X represents the most recent action.

l Redo--The Redo command reverses the most recent Undo action. In other words, it returns 
things. The actual command reads Redo X, where X represents the last action.

l Cut, Copy, Paste--These commands are standard Windows commands. Cut removes the 
selected item from the document and places it in the Clipboard. Copy places the item in the 
Clipboard but also leaves it in place in the document. Paste transfers the item from the 
Clipboard to the document.

l Paste Special--Brings up the Convert Text dialog box. You choices are to paste the text into the 
currently active document as one formatted paragraph (it will concatenate separate paragraphs), 
as the same number of formatted paragraphs as in the original, as normal paragraphs (normal 
style), as normal paragraphs with line breaks, or as raw HTML.

l Clear--Cuts the selected text from the document without putting it into the Clipboard.

l Select All--Highlights everything in the document. This command is useful for copying, 
deleting, or reformatting the entire contents of the document.

l Find--Yields the Find dialog box, with which you can search for text strings in the currently 
loaded document or across the entire active web.

l Replace--Brings up the Replace dialog box shown in Figure 3.3. Type, in the Find What field, 
the text string you want to locate; type, in the Replace With field, the text string that will take 
the place of the located string. Two columns of radio buttons and a column of check boxes 
guide you through the options. In Find Where, you can choose to find the string in the selected 
page(s) or across the entire web, while in Direction you can tell FrontPage to search from the 
cursor position to the beginning of the document (Up) or from the cursor position to the end of 
the document (Down).

l The Options area lets you select any combination of the three options. You can match the entire 
word (not portions of words) and you can match upper- or lowercase characters. You can also 
locate the string in the HTML codes themselves. The buttons at the right of the dialog box 
enable you to find the next (or the first) instance of the string or simply cancel the entire 
process at any point. The Replace button works in conjunction with the Find Next button: Once 
a string is found, click Replace to change that selection only, after which the next instance of 
the string will be searched for. If you’re certain at any time that you want to replace all the 
specified strings in the text without stopping at each one to confirm, you can press the Replace 
All button.

l Check Out, Check In, Undo Check Out--These three commands handle the check out and 
check in features of FrontPage, designed to let only one author work on a document at one 
time. A web author cannot load a checked-out page. This command is covered in greater detail 
in Chapter 18.
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FIGURE 3.3 The Find dialog box is identical to the Replace dialog box, except that the Find dialog 
box does not contain the Replace With field.

The View Menu

The View menu lets you change what the FrontPage screen displays:

l Page, Folders, Reports, Navigation, Hyperlinks, Tasks--These first five menu items work 
identically to the icons on the Views bar that runs down the left side of the FrontPage screen.

l Views Bar, Folder List--These commands toggle the Views bar and the Folder List 
respectively. When checked, those features show on the FrontPage screen.

l Reveal Tags--This command reveals the HTML tags in the currently loaded document. Figure 
3.4 shows a document with tags revealed.

FIGURE 3.4 You can see the HTML tags when you select the Reveal Tags option. You can edit the 
document with these tags in place. 

l Toolbars--This menu item cascades into a list of available toolbars. These options are covered 
in the "FrontPage’s Toolbars" section of this chapter.

l Refresh--Reloads the current document into the main window. This is useful if the display 
becomes mangled, or for seeing the document with all the changes made. You are asked to save 
any changes to the file before Refresh takes place.

The Insert, Format, Tools, and Table Menus

These menus are covered in detail throughout Part II, in the chapters devoted to their respective tasks. 

The Window Menu

From the Window menu, you can open a new FrontPage window (another instance of FrontPage) or 
select from one of the currently open documents. Up to nine open documents will appear in the list; if 
more are open you can access them by selecting Windows. Each currently running instance of 
FrontPage has its own separate Window list (although all maintain the same Recent Files and Recent 
Webs list in the File menu).

The Help Menu

From here you can access FrontPage’s Help system. The Office Assistant can also do this for you.

FrontPage’s Toolbars

By default, FrontPage 2000 loads with two toolbars immediately below the menu bar. Several other 
toolbars are included with the package, and they can be called up at any time via the View, Toolbar 
command. Furthermore, you can customize the toolbars to your specific needs. Here you briefly 
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examine the toolbars and look at the customization process.

Figure 3.5 shows FrontPage 2000 with all the toolbars visible. Several are inactive, with grayed-out 
features. The features become active only if you’re performing a task to which they apply. For 
instance, the third toolbar down from the menu bar in Figure 3.4, DHTML Effects, is active because a 
Dynamic HTML (page 506) event is being added to the highlighted component in the main window. 
If that component were a graphic, the Picture toolbar (the fifth one down) would be active. 

You can change the positions of any of the toolbars. To do so, move the cursor to the far left, where a 
small vertical line marks the start of the toolbar. The cursor will turn into a four-point arrow; in 
Figure 3.5 you can see it at the far edge of the second toolbar from the bottom. You can drag the 
toolbar left, right, up, or down. If the toolbar is docked with other toolbars (flush against them so that 
it does not have its own title bar and exit (X) button), as are all the toolbars in Figure 3.5, you can 
drag the toolbar along the other docked bars and drop it where you want it. If you drag it away from 
the docked toolbars, the toolbar becomes a floating toolbar, which you can move anywhere on the 
screen. By default, only the Standard and Formatting toolbars are docked; the rest, when summoned 
with the View, Toolbars command, appear as floating toolbars. You move a floating toolbar as you’d 
move any other window, by clicking and holding its title bar.

FIGURE 3.5 In this figure, the toolbars are all docked along the top of the FrontPage screen. You 
can dock them to the left, right, or bottom, or you can leave them floating.

The Standard Toolbar

The Standard toolbar contains many icons common to Windows programs. Only a few are specific to 
FrontPage itself. Follow these from left to right (assuming the default toolbar configuration). 
Depending on the view you are working in, as well as whether or not a web or page is actually loaded 
into FrontPage, some of the icons will be grayed out.

l New Page--Click to open a new page in the main FrontPage window. Click the down arrow 
beside the icon to start a new page, task, folder, or web. Corresponds to File, New.

l Open--Click to yield the Open File dialog box. Click the down arrow to choose between the 
Open File and the Open Web dialog box. Corresponds to File, Open.

l Save--Saves the current document to your hard drive (or networked drive). Brings up the Save 
As dialog box if the document is unsaved. Corresponds to File, Save.

l Publish Web--Begins the Web publishing process, covered in Chapter 16. Corresponds to File, 
Publish Web.

l Folder List--Shows or hides the Folder List. Corresponds to View, Folder List.

l Print--Brings up the Print dialog box. Corresponds to File, Print.

l Preview in Browser--Opens a browser window with the currently active document loaded. 
Corresponds to File, Preview in Browser.

l Spelling--Initiates the spell-check process, covered in Chapter 18.
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l Cut, Copy, Paste--Next three icons. Correspond to Edit, Cut; Edit, Copy; and Edit, Paste, 
respectively.

l Format Painter--Activates the Format Painter procedure, covered in Chapter 5, "Enhancing 
Pages with Graphics and Multimedia."

l Undo--Click to undo the most recent action. Click the down arrow to reveal a list of actions 
ordered from most to least recent and select the action you want undone. Corresponds to Edit, 
Undo.

l Redo--Click to redo the most recent action. Click the down arrow to reveal a list of actions 
ordered from most to least recent and select the action you want redone. Active only if a valid 
Redo action is possible. (Not all Undo actions can be redone.) Corresponds to Edit, Redo.

l Insert Component, Table, Picture, Hyperlink--Next four icons. These commands open the 
dialog boxes for adding a FrontPage component, a table, a graphic, and a hyperlink, 
respectively. Click to undo the most recent action. Click the down arrow to reveal a list of 
actions ordered from most to least recent and select the action you want undone. Correspond to 
the same commands on the Insert menu.

l Back, Forward, Refresh, Stop--Next four icons. These commands are similar to those in any 
Web browser. Back takes you to the previous document, Forward to the next one. The down 
arrows beside let you choose a specific document to return to or to go ahead to. Refresh reloads 
the current document. Stop halts the loading of a page from the Web. Click to undo the most 
recent action. Click the down arrow to reveal a list of actions ordered from most to least recent 
and select the action you want undone. Only Refresh has a corresponding menu command: 
View, Refresh.

l Show All--Reveals formatting marks, principally carriage returns. This is not the same as 
Reveal Tags, which displays all HTML tags.

l Help Tool--Click to activate and then click the item for which you’d like help. This activates 
the Help system.

l More Buttons--The down arrow at the far right of each toolbar lets you customize FrontPage’s 
interface by adding or removing buttons, changing keyboard shortcuts, and so forth. This is 
covered in "Customizing the FrontPage Interface" in this chapter. Corresponds to Tools, 
Customize.

The Other Toolbars

The remaining toolbars are covered throughout this book, in chapters devoted to the features that 
employ them. Here is an introductory overview: 

These tables do not appear in FrontPage until you select them from the cascading menu under Views, 
Toolbars. Once you display a toolbar, it will remain displayed, even after exiting and restarting 
FrontPage. You must deselect it if you wish to hide it. Toolbars can be placed anywhere on the 
screen, either as floating toolbars or docked along the sides, top, or bottom of the FrontPage display.
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l Formatting toolbar--There’s very little difference between the Formatting toolbar in FrontPage 
and the Formatting toolbar of most other Windows application (especially Microsoft’s). With it 
you can format characters with font styles and sizes by boldfacing, italicizing, and underlining, 
and by left- or right-justifying and centering. You can produce bulleted and numbered lists, and 
you can increase and decrease the indentation in outlines. You can also change character colors.

l The only significant difference is the Styles drop-down list (at far left of the toolbar). Here you 
find HTML styles corresponding to the HTML standards, rather than to the kinds of styles 
found in a word processor. These styles are covered in Chapter 12, "Using Style Sheets with 
Individual Pages and Full Sites."

l DHTML effects toolbar--The DHTML Effects toolbar lets you add dynamic HTML effects to 
your document. The toolbar operates syntactically; the fields create a kind of grammatical 
sentence to explain the effect. For example, when filled in the fields might read--in order--On 
Page load, Apply Fly in, from bottom, and that’s precisely the effect that is generated. 
This toolbar is covered in Chapter 25, "Making Your Pages and Webs More Dynamic."

l Navigation toolbar--Operational only when the Navigation view is selected (not in Page view at 
all). This toolbar is covered in Chapter 15, "Working with an Existing Web."

l Picture toolbar--The Picture toolbar activates whenever a graphic is selected in the main 
FrontPage window. Covered in Chapter 5.

l Positioning toolbar--Lets you position page elements precisely. 

l Reports toolbar--Active only when the Reports view is active in the main FrontPage window; 
this toolbar lets you select from a variety of reports. Covered in Chapter 18.

l Table toolbar--Active when a table is selected; this toolbar lets you format and position tables 
in documents. Covered in Chapter 8, "Creating Tables."

Customizing the FrontPage Interface

The menus and toolbars in FrontPage are designed with the majority of users in mind, but all users 
utilize software differently and most want a customized interface. The FrontPage 2000 interface is 
somewhat customizable for this reason. It’s not as customizable as other Office applications, but it’s 
not bad.

You’ve already seen two major customization methods in this chapter. The first is changing the major 
screen components: The View bar and Folder List can be shown or hidden at will. The second is the 
displaying and positioning of toolbars. You can display whatever toolbars you want (including getting 
rid of the default toolbars), and you can move them wherever you want on the screen. The trick is to 
make these basic interface issues as useful to you as possible, and to experiment until you get it the 
way you want it.

FrontPage 2000 offers formal customization methods as well. Those are covered in detail here.



Special Edition Using Microsoft FrontPage 2000 - Chapter ...: Windows, Icons, and Menu Page 13 of 15

file://I:\chapters\i\ir141.html 3/22/01

Adding Toolbar Buttons with the More Buttons Arrow

At the far right of every toolbar is a down arrow called More Buttons. Clicking this arrow yields a 
button named Add or Remove Buttons; moving the pointer over this button yields a list of the buttons 
currently on the toolbar. You can click whichever of these you want in order to remove it from the 
toolbar and then return to this button to re-add the buttons later (if you prefer).

The Reset Toolbar and Customize commands are at the bottom of the list of available buttons. Reset 
Toolbar restores the toolbar to its default configuration--the way it was when you installed FrontPage 
2000. Customize yields the Customize dialog box, which is covered here.

Working with the Customize Dialog Box

The Customize dialog box is available either via the Add or Remove Buttons option in More Buttons, 
or via Tools, Customize on the menu bar. The dialog box, shown in Figure 3.6, contains three tabs: 
Toolbars, Commands, and Options. Each offers different customization options.

Customizing and Creating Toolbars

The Toolbars tab lets you select the toolbars you want displayed on the screen. The toolbar 
immediately appears when you click the check box. This corresponds exactly to the View, Toolbars 
command on the menu bar. The Reset button returns the buttons on the selected toolbar to the 
defaults.

FIGURE 3.6 The three tabs on the Customize dialog box reveal different means of tailoring the 
interface.

The New button lets you create a new toolbar. You can name it whatever you like in the resulting 
New Toolbar dialog box, and once the toolbar is created you can rename it by selecting it and 
clicking the Rename button.

When you click OK in the New Toolbar dialog box, the toolbar name is added to the list of available 
toolbars. The actual toolbar appears as an empty toolbar beside the Customize dialog box.

Click the Commands tab to add buttons to this new toolbar. The Categories pane shows the menu bar 
titles, and the Commands pane shows the commands assigned to any particular menu when you click 
it. You can drag any command from the Commands pane to the new toolbar, where it will appear as a 
button. A vertical bar helps you position the new button on the toolbar.

The Commands tab’s Description button helps you understand what the command actually does. 
When you select a category or command and click Description, a short description of that item 
appears from FrontPage’s Help system.

The Modify Selection button yields a menu of options that you can apply to the buttons on your new 
toolbar. The Reset command abandons all changes you’ve made to the currently selected button, 
while Delete gets rid of the button. The Name command consists of a field in which you can edit the 
button name. Place an ampersand (&) to the left of the character you chose as the keyboard shortcut 
character.
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With the next two commands, you can copy the button image to the Clipboard or paste the current 
image from the Clipboard to the toolbar. (Note that you can work with identical images in different 
toolbars this way.) Edit Button Image yields the Button Editor and a simplified graphics applet that 
lets you redraw and recolor the button. Change Button Image yields a palette of button images for you 
to choose from.

The next four commands let you establish how the button will appear. The Default Style is an image, 
while Text Only (Always) eliminates the image and replaces it with the name of the button. Text and 
Image shows both the name and the icon. You can select different styles for each icon on the toolbar.

Troubleshooting

Once in a long while FrontPage 2000 gets a bit forgetful and throws you into a Page view sub-view 
you don’t actually want. If you open a file in Page view and find yourself looking at an uneditable file 
as if it’s in a browser, or even worse, a file filled with HTML coding, don’t panic. Nothing evil has 
entered your machine. Simply check the three tabs at the bottom of the main window of the Page 
view and make sure that FrontPage is displaying the sub-view you want: Normal view is the 
WYSIWYG editing view most people work in; HTML view shows you raw HTML code; Preview 
lets you see what your document will look like in a browser window. Click the view you want.

Sometimes you’ll find yourself having difficulty reading complex HTML code. To make it easier to 
read, use the HTML Source section on the Page Options dialog. Select Page Options from the Tools 
menu, then click the HTML Source tab. From here you can choose to Preserve existing HTML code 
exactly as it is, or you can Reformat it using the rules you define in the bottom half of the dialog. 
Several options are available, including the spacing before and after each HTML tag or container. 
You can also specify that HTML tags or attributes be all in lowercase, to help you distinguish among 
them. From the Color Coding tab of the Page Options dialog, you can carry the HTML Source display 
further by selecting different colors for normal text, HTML tags, the names of attributes, the values of 
attributes, comments within the code, and scripts. Using all of these features together, you can 
customize the HTML Source display precisely to help you read the code most efficiently.

Designers Corner

FrontPage 2000’s Page view is extremely useful for a number of reasons but, like most Microsoft 
products today (and for that matter, most products by any software publisher), it significantly fails to 
take into account that good old 14-inch monitors are still very much in use. For that matter, so are 
many 15-inch monitors with 800¥600 resolution. FrontPage offers most productivity when used with 
a larger monitor--17 inches or more--at resolutions between 1024¥768 and 1600¥1200, and with a 
color depth of 256 colors and up. But not everybody has that, and even those who do often have a 
second computer with lesser capabilities.

If you have a smaller display, a few options are open to you. First, a significant portion of the 
FrontPage display is taken up by items other than the main view. When in Page view, specifically, the 
Folder List and the Views bar occupy the left 25% (by default) of the display. To increase your 
working area--that is, the main viewing pane--you can hide or shrink both of them. To hide the Folder 
List, uncheck the Folder List item from the View menu. To hide the Views bar, uncheck Views Bar 
from the View menu. Presto! Both are gone, and your work area is enlarged.
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Doing without the Views bar isn’t difficult, because all the views are available from the View menu 
anyway. You’ll want the Folder List quite often, though, so you’ll have to toggle it on and off (by 
checking and unchecking from the View menu). But you don’t actually have to get rid of either. 
Instead, you can simply shrink them. To do so, move the pointer over the vertical border that runs 
along the right side of the item you want to shrink until the arrow changes to a double arrow. Now 
drag the border to the left until it is the size you want. 

In the case of the Views bar, the icons will keep moving closer and closer to the left border, and the 
icon titles will abbreviate themselves. You can shrink this bar by two-thirds and still have it remain 
readable. Shrinking the Folder List, by contrast, simply hides an increasing amount of the folder and 
file information. Even so, you rarely need the full folder or filename to work with, and when you do 
you can always enlarge the list again.

Although it’s much smaller than the others, you can also get rid of the status bar (at the bottom of the 
display). To do so, select Options from the Tools menu, then uncheck the Show status bar option. To 
get it back, reverse the process.

Unfortunately, FrontPage does not offer the kind of Zoom feature offered in other Office 2000 
products (why it doesn’t we have absolutely no idea--it would be extremely useful). There are, 
however, a few other ways to save screen real estate. First, you can minimize the number of toolbars. 
Select Customize from the Tools menu, and in the Toolbars tab uncheck the toolbars you don’t need. 
In fact, start by unchecking them all and seeing if you can get along without them permanently. The 
same dialog box lets you switch from small to large icons in the toolbars, useful if you want to 
minimize but not hide the toolbars. Click on the Options tab and uncheck the Large icons option. 
Also from the Options tab, you can tell FrontPage to save you a line of screen space by having the 
standard and Formatting menus (the two default menus) share only one line. 


